|IOASIC(4)||Device Drivers Manual (alpha)||IOASIC(4)|
ioasic — baseboard
IO control ASIC for DEC TURBOchannel systems
ioasic0 at tc? slot ? offset ?
ioasic driver provides support for the
DEC proprietary IOCTL ASIC found on DEC 3000 TURBOchannel machines.
ioasic provides hardware DMA channels
and interrupt support for several baseboard devices, including one
asc(4) SCSI device with a scatter/gather DMA
channel, an mc146818-compatible
mcclock, an Am7930
audio device bba(4), two
zs(4) dual-port serial devices, and an AMD
7990 LANCE le(4) Ethernet interface.
ioasic is also used for the audio/ISDN
hardware on audio-equipped TURBOchannel Alphas, where the
ioasic hardware provides a scatter-gather DMA
channel between the 16-bit device and the 32-bit
DMA address space.
Support for scatter-gather DMA eliminates the need for additional copying.
ioasic driver first appeared in
NetBSD 1.1, derived from DECstation boot-time
configuration code in 4.4BSD.
|November 2, 2017||OpenBSD-current|