|INITTODR(9)||Kernel Developer's Manual||INITTODR(9)|
initialize system time
inittodr() function determines the
time and sets the system clock. It tries to pick the correct time using a
set of heuristics that examine the system's battery-backed clock and the
time reported by the file system, as given in base.
Those heuristics include:
Once a system time has been determined, it is passed to the
inittodr() function prints diagnostic
messages if it has trouble figuring out the system time. Conditions that can
cause diagnostic messages to be printed include:
Each system's heuristics for picking the correct time are slightly different.
|April 3, 2016||OpenBSD-current|