|IEEE80211_IOCTL(9)||Kernel Developer's Manual||IEEE80211_IOCTL(9)|
802.11 interface ioctl commands
ifnet *ifp, u_long
These functions are typically invoked by drivers in response to requests for information or to change settings from the userland.
function provides a default implementation of the
ifioctls commands for 802.11 drivers. The call signature is identical to
that of the if_ioctl member found in
struct ifnet, however, many drivers store attributes
IEEE80211_IOC_STATIONNAME in the driver's
private soft state structure, so driver writers may prefer to use this as
the catch-all in a switch statement to avoid code duplication.
ieee80211 series of functions first
appeared in NetBSD 1.5, and were later ported to
FreeBSD 4.6 and OpenBSD
|July 17, 2013||OpenBSD-current|