|IWI(4)||Device Drivers Manual||IWI(4)|
iwi — Intel
PRO/Wireless 2200BG/2225BG/2915ABG IEEE 802.11a/b/g wireless network
iwi* at pci?
iwi driver provides support for Intel
PRO/Wireless 2200BG/2915ABG Mini PCI and 2225BG PCI network adapters.
These are the modes the
iwi driver can
iwi driver can be configured to use
Wired Equivalent Privacy (WEP) or Wi-Fi Protected Access (WPA-PSK and
WPA2-PSK). WPA is the current encryption standard for wireless networks. It
is strongly recommended that WEP not be used as the sole mechanism to secure
wireless communication, due to serious weaknesses in it. The
iwi driver relies on the software 802.11 stack for
both encryption and decryption of data frames.
The driver needs at least version 3.1 of the following firmware files, which are loaded when an interface is brought up:
These firmware files are not free because Intel refuses to grant distribution rights without contractual obligations. As a result, even though OpenBSD includes the driver, the firmware files cannot be included and users have to download these files on their own. The official person to state your views to about this issue is firstname.lastname@example.org.
A prepackaged version of the firmware can be installed using fw_update(1).
The following example scans for available networks:
# ifconfig iwi0 scan
The following hostname.if(5) example configures iwi0 to join network “mynwid”, using WPA key “mywpakey”, obtaining an IP address using DHCP:
nwid mynwid wpakey mywpakey dhcp
iwi driver first appeared in
iwi driver was written by
This driver does not support powersave mode.
|March 29, 2019||OpenBSD-current|