|ESM(4)||Device Drivers Manual (i386)||ESM(4)|
esm — Dell
Embedded Server Management
esm0 at mainbus?
esm driver provides support for the
monitoring of the environmental sensors present in a variety of Dell
servers. The hardware monitoring is accessed via the
Devices compatible with the
esm driver can
provide an arbitrary set of sensors which may include the following
Sensor data is updated every 10 seconds.
The Embedded Server Management framework has been replaced in more recent Dell systems with the Intelligent Platform Management Interface. Servers using the Intelligent Platform Management Interface may be monitored by the ipmi(4) driver.
ESM provides watchdog(4) timer functionality. Once configured, if the watchdog is not reset within a certain period of time, it will timeout and the server will reset. The reset will occur regardless of the recoverability of the hang or crash.
Example of enabling a watchdog:
# sysctl kern.watchdog.period=10
In this case if the watchdog is not reset, it'll reboot the server after roughly 10 seconds.
Example of disabling the watchdog:
# sysctl kern.watchdog.period=0
esm driver first appeared in
|July 16, 2013||OpenBSD-current|