|CDBOOT(8)||System Manager's Manual (i386)||CDBOOT(8)|
i386-specific second-stage CD-specific bootstrap
cdboot is a modified version of the i386
second-stage bootstrap program, boot(8),
configured to be run by the OpenBSD El Torito CD-ROM
boot sector cdbr.
will look for an /etc/boot.conf configuration file
on the CD-ROM. If it finds one, it processes the commands within it.
boot.conf processing can be skipped by holding down
either Control key as
cdboot then sits in a loop, processing
commands given by the user. It accepts all the commands accepted by
If no commands are given for a short time,
cdboot will then attempt to load an
OpenBSD kernel from the CD. It first looks for the
install kernel bsd.rd in the standard i386 release
directory (e.g. /3.6/i386/bsd.rd), then for
/bsd. It may be told to boot an alternative kernel,
either by commands in the boot.conf file, or by
commands typed by the user at the
cdbootconfiguration file (read from CD)
Boot the install kernel:
Curtis E. Stevens and Stan Merkin, El Torito Bootable CD-ROM Format Specification, Version 1.0, January 25, 1995.
cdboot program first appeared in
By default, many CD creation programs restrict filenames to the
MS-DOS 8.3 format. Unless this is changed,
will not be able to read its
boot.conf(8) file. For example, with
-l option should be specified.
ls command does not work on ISO 9660
(cd9660) filesystems, which are used on most CDs.
|March 30, 2016||OpenBSD-current|