|HZ(9)||Kernel Developer's Manual||HZ(9)|
profhz — system time
extern int hz;
extern int tick;
extern int tickadj;
extern int stathz;
extern int profhz;
The system is driven by hardclock(9) interrupts, which occur at hz frequency, and are used to keep track of real time.
On systems where another independent clock is available, it is set at stathz frequency, and used to gather timing statistics. Ideally, it would be better to drive stathz with a slightly randomized clock, that is still a fixed number on average, as this would prevent malicious processes from working around the scheduler. If a separate clock is not available, stathz is set to hz.
If profiling is enabled, the clock normally used to drive stathz may be run at a higher rate profhz, which must be a multiple of stathz. This will give higher resolution profiling information.
These system variables are available by reading
|January 14, 2019||OpenBSD-current|