|HVN(4)||Device Drivers Manual||HVN(4)|
hvn — Hyper-V
hvn* at hyperv?
hvn driver provides support for a
Network Virtual Service Client (NetVSC), a virtual networking interface that
relays device requests to the Virtual Service Provider (VSP) in the
management operating system via the VMBus.
NetVSC emulates an RNDIS 1.0 compliant device on top of a custom NVS protocol operating over the VMBus channel ring.
Individual networking interfaces can be renamed by issuing a
Rename-VMNetworkAdapter PowerShell command in the
management domain. In order to enable sending and receiving of IEEE 802.1q
(VLAN) frames, the virtual port needs to be put into Trunk
mode with the
hvn driver first appeared in
|October 7, 2016||OpenBSD-current|