|MEM(4)||Device Drivers Manual (hppa)||MEM(4)|
mem* at mainbus0 flags 0x0000
memdriver controls and restricts access to the systems memory by the hardware buses and the processor.
It also provides an interface to userland through the special files /dev/mem and /dev/kmem. Physical memory is accessed through /dev/mem, while kernel virtual memory is accessed through /dev/kmem. Access to kernel virtual addresses not currently mapped to memory will fail. On hppa, the physical memory range is always contiguous and starts at address 0; kernel virtual memory begins at address 0 as well.
memor cpu(4) device probe.
In this case, a different initialization strategy can be achieved by setting flags to 0x0001 (see boot_config(8) for details).
|January 12, 2018||OpenBSD-current|