|HOSTNAME(7)||Miscellaneous Information Manual||HOSTNAME(7)|
(with no trailing dot).
Hostnames are often used with network client and server programs, which must generally translate the name to an address for use. (This function is generally performed by the library routine gethostbyname(3).) Hostnames are resolved by the Internet name resolver in the following fashion.
If the name consists of a single component, i.e., contains no dot,
and if the environment variable
HOSTALIASES is set
to the name of a file, that file is searched for any string matching the
input hostname. The file should consist of lines made up of two whitespace
separated strings, the first of which is the hostname alias, and the second
of which is the complete hostname to be substituted for that alias. If a
case-insensitive match is found between the hostname to be resolved and the
first field of a line in the file, the substituted name is looked up with no
If the input name ends with a trailing dot, the trailing dot is removed, and the remaining name is looked up with no further processing.
If the input name does not end with a trailing dot, it is looked up by searching through a list of domains until a match is found. The default search list includes first the local domain, then its parent domains with at least 2 name components (longest first). For example, in the domain CS.Berkeley.EDU, the name lithium.CChem will be checked first as lithium.CChem.CS.Berkeley.EDU and then as lithium.CChem.Berkeley.EDU. Lithium.CChem.EDU will not be tried, as there is only one component remaining from the local domain. The search path can be changed from the default by a system-wide configuration file (see resolv.conf(5)).
hostnamemanual page appeared in 4.2BSD.
|May 29, 2017||OpenBSD-current|