|HARMONY(4)||Device Drivers Manual (hppa)||HARMONY(4)|
CS4215/AD1849 audio device
harmony* at gsc? irq 13
audio* at harmony?
harmony device uses the Crystal
Semiconductor CS4215 16-Bit Multimedia Audio Codec or Analog Devices AD1849
SoundPort(R) Stereo Codec chip to implement the audio device interface
described in audio(4). This device is
found on most HP PA-RISC workstations. The
has a maximum precision of 16 bits and has a stereo input and stereo
On HP 9000/712 models
provides two additional channels for an add-on card with two fax/voice
One of the hardware registers reflects the state of the CHI bus that is used to communicate with the codec and thus being sampled at a low accuracy secondary frequency (such as timeout(9)) produces poor quality random bit stream that is fed into the entropy pool of random(4).
OpenBSD support for
harmony first appeared in OpenBSD
To trigger entropy collection CHI bus has to be programmed into the data mode that happens once a single buffer of data has been played or recorded.
|May 31, 2007||OpenBSD-current|