|GPIOOW(4)||Device Drivers Manual||GPIOOW(4)|
gpioow* at gpio? offset 0 mask 0x1
gpioow* at gpio?
onewire* at gpioow?
gpioowdriver allows bit-banging a 1-Wire bus as a master using one GPIO pin. The pin is used as a data signal. The GPIO pin must be able to drive an output and read an input.
The pin number can be specified in the kernel configuration with
the offset locator. The mask
locator should always be 0x1 in this case. The offset
and mask can also be specified when
gpioow is attached at runtime using the
ioctl(2) on the
gpioowdriver first appeared in OpenBSD 4.0.
gpioowdriver was written by Alexander Yurchenko <email@example.com>.
|July 16, 2013||OpenBSD-current|