|GPIODCF(4)||Device Drivers Manual||GPIODCF(4)|
gpiodcf* at gpio? offset 0 mask 0x1
gpiodcf* at gpio?
gpiodcfdriver decodes the DCF77 time signal code using one GPIO pin. The pin is used as a data signal. The GPIO pin must be able to read an input.
The pin number can be specified in the kernel configuration with
the offset locator. The mask
locator should always be 0x1 in this case. The offset
and mask can also be specified when
gpiodcf is attached at runtime using the
ioctl(2) on the
gpiodcf implements a timedelta sensor and
the delta (in nanoseconds) between the received time information and the
local time can be accessed through the
sysctl(8) interface. The clock type is
indicated in the sensor description:
The quality of the timedelta is reported as the sensor status:
gpiodcfdriver first appeared in OpenBSD 4.5.
gpiodcfdriver was written by Marc Balmer <firstname.lastname@example.org>.
|June 7, 2015||OpenBSD-current|