|GETTY(8)||System Manager's Manual||GETTY(8)|
gettyprogram is called by init(8) to open and initialize the tty line, read a login name, and invoke login(1).
The argument tty is the special device file in /dev to open for the terminal (for example, ttyh0). If there is no argument or the argument is ‘-’, the tty line is assumed to be open as file descriptor 0.
The type argument can be used to make
getty treat the terminal line specially. This
argument is used as an index into the
gettytab(5) database, to determine the
characteristics of the line. If there is no argument, or there is no such
table, the default table is used. If there is no
/etc/gettytab a set of system defaults is used. If
indicated by the table located,
getty will clear the
terminal screen, print a banner heading, and prompt for a login name.
Usually either the banner or the login prompt will include the system
Most of the default actions of
be circumvented, or modified, by a suitable
getty program can be set to timeout
after some interval, which will cause dial up lines to hang up if the login
name is not entered reasonably quickly.
gettyis started by init(8), with a process priority, umask, and resource limits based on the “default” entry in /etc/login.conf.
gettyprogram appeared in Version 6 AT&T UNIX.
|November 15, 2014||OpenBSD-current|