|FBTAB(5)||File Formats Manual||FBTAB(5)|
fbtab — change
device protection upon login
fbtab file contains lines which
specify how the permissions and ownership of various system files should be
changed based on the user's login device name.
Comments start with a ‘
and extend to the end of the line. Blank lines or lines with only a comment
All other lines consist of three fields delimited by whitespace.
:’) delimited list of device paths (e.g., “/dev/console:/dev/fd0a:/dev/wskbd*”). Device paths may include shell-style globbing patterns (see glob(7)), potentially matching multiple devices.
fbtab file is used by
chown(2) the specified files to the user
who has performed a login. Additionally,
chmod(2) is used to set the devices to the
specified permission. When a user logs out,
init(8) is responsible for performing the
inverse operation, which results in the files once again belonging to
Guido van Rooij
|April 21, 2022||OpenBSD-current|