|DISKMAP(4)||Device Drivers Manual||DISKMAP(4)|
diskmapdriver provides userland applications with a means to map a disklabel UID to an actual device and open that device in one atomic operation. This is achieved via the DIOCMAP ioctl(2) command.
The ability to use a disklabel UID is helpful in situations where a disk may appear to the operating system under different device names. For example, plugging USB keys into differently configured systems (think sd0 or sd1), or swapping between IDE and AHCI on a disk controller (wd0 or sd0). Although the device names may change, the operating system is still able to identify the disk by its UID.
diskmapdriver first appeared in OpenBSD 4.8.
diskmapdriver was written by Joel Sing.
|September 10, 2015||OpenBSD-current|