|DHCLIENT(8)||System Manager's Manual||DHCLIENT(8)|
dhclient — Dynamic
Host Configuration Protocol (DHCP) client
dhclient uses the Dynamic Host
Configuration Protocol (DHCP), or its predecessor BOOTP, to configure a
network interface. Information typically provided via DHCP includes IPv4
address and subnet mask, default route, and domain name server.
dhclient can be run on the command line,
or at boot time by specifying ‘dhcp’ in the appropriate
dhclient sets the
flag on interface. If the flag is later cleared by
dhclient will continue to obtain leases normally but
it will not apply any changes to the interface or the host until
ifconfig(8) restores the flag.
The options are as follows:
dhclientwill run in the foreground and log to stderr.
dhclientwill ignore any values provided by leases for the options specified. This list will override any ignore statements in dhclient.conf(5). options must be a comma separated list of valid option names. Invalid option names will cause the entire list to be discarded.
dhclientto write two pseudo-leases, “offered” and “effective”, to the specified file. “offered” will be the lease offered by the DHCP server; “effective” will be the modified lease bound to the interface.
dhclientexits after removing the active lease from /var/db/dhclient.leases.⟨IFNAME⟩, deleting the address the lease caused to be added to the interface, truncating any option file specified by
-Land sending a DHCPRELEASE packet to the server that supplied the lease.
If there is no
the specified interface, or
dhclient has no
active lease configured, no action is performed.
dhclientto log more information.
-vis implied if either
The DHCP protocol allows a host to contact a central server which maintains a list of IP addresses which may be assigned on one or more subnets. A DHCP client may request an address from this pool, and then use it on a temporary basis for communication on the network. The DHCP protocol also provides a mechanism whereby a client can learn important details about the network to which it is attached, such as the location of a default router, the location of a name server, and so on.
/etc/dhclient.conf for configuration instructions.
It then attempts to configure the network interface
interface with DHCP. The special value
“egress” may be used instead of a network interface name. In
dhclient will look for the network
interface currently in the interface group “egress” and
configure it with DHCP. If there is more than one network interface in the
dhclient will exit with an error.
When configuring the interface,
attempts to remove any existing addresses, gateway routes that use the
interface, and non-permanent arp(8) entries.
dhclient automatically exits whenever a new
dhclient is run on the same interface.
Once the interface is configured,
constructs a resolv.conf(5) file. It
does this only if any of the options
domain-search are present (note that these options
may be offered by the DHCP server but suppressed by
dhclient.conf(5)). If a
resolv.conf is constructed,
dhclient appends any
contents of the
resolv.conf.tail(5) file, which
are read once at start up. The constructed resolv.conf is copied into
/etc/resolv.conf whenever the default route goes out
dhclient is running on.
dhclient monitors the system for changes to the
default route and re-checks whether it should write its resolv.conf when
possible changes are detected.
In order to keep track of leases across system reboots and server
dhclient keeps a list of leases it has
been assigned in the
file. IFNAME represents the network interface of the
DHCP client (e.g. em0), one for each interface. On startup, after reading
the dhclient.conf(5) file,
dhclient reads the leases file to refresh its memory
about what leases it has been assigned.
Old leases are kept around in case the DHCP server is unavailable
dhclient is first invoked (generally during the
initial system boot process). In that event, old leases from the
file which have not yet expired are tested, and if they are determined to be
valid, they are used until either they expire or the DHCP server becomes
A mobile host which may sometimes need to access a network on
which no DHCP server exists may be preloaded with a lease for a fixed
address on that network. When all attempts to contact a DHCP server have
dhclient will try to validate the static
lease, and if it succeeds, it will use that lease until it is restarted.
A mobile host may also travel to some networks on which DHCP is not available but BOOTP is. In that case, it may be advantageous to arrange with the network administrator for an entry on the BOOTP database, so that the host can boot quickly on that network rather than cycling through the list of old leases.
R. Droms, Interoperation Between DHCP and BOOTP, RFC 1534, October 1993.
R. Droms, Dynamic Host Configuration Protocol, RFC 2131, March 1997.
S. Alexander and R. Droms, DHCP Options and BOOTP Vendor Extensions, RFC 2132, March 1997.
T. Lemon and S. Cheshire, Encoding Long Options in the Dynamic Host Configuration Protocol (DHCPv4), RFC 3396, November 2002.
T. Lemon, S. Cheshire, and B. Volz, The Classless Static Route Option for Dynamic Host Configuration Protocol (DHCP) version 4, RFC 3442, December 2002.
N. Swamy, G. Halwasia, and P. Jhingram, Client Identifier Option in DHCP Server Replies, RFC 6842, January 2013.
The current implementation was reworked by Henning Brauer <email@example.com>.
|July 31, 2019||OpenBSD-current|