|CONFIG(8)||System Manager's Manual||CONFIG(8)|
config — build
kernel compilation directories or modify a kernel
In the first synopsis form, the
program creates a kernel build directory from the kernel configuration file
specified by config-file.
In the second synopsis form,
editing of the kernel binary specified by infile.
Devices may be enabled, disabled, or modified without recompiling, by
editing the kernel executable. Similarly, the same editing can be done at
boot-time, using the in-kernel editor, as described in
For kernel building, the options are as follows:
configacts as if the lines “makeoptions PROF="-pg"” and “option GPROF” appeared in the specified kernel configuration file. In addition, “.PROF” is appended to the default compilation directory name.
-p flag is expected to be used for
“one-shot” profiles of existing systems; for regular
profiling, it is probably wiser to make a separate configuration
containing the makeoptions line.
For kernel modification, the options are as follows:
-oshould be given to specify an alternate output file.
boot -cwas used). If so, compare the running kernel with the kernel to be edited (infile). If they seem to be the same, apply all configuration changes performed at boot. Using this option requires read access to /dev/mem, which may be restricted based upon the value of the kern.allowkmem sysctl(8).
The output of
config consists of a number
of files, principally ioconf.c (a description of I/O
devices that may be attached to the system) and a
Makefile, used by
make(1) when building the kernel.
config stops due to errors, the
problems reported should be corrected and
should be run again.
config attempts to avoid
changing the compilation directory if there are configuration errors, but
this code is not well-tested and some problems (such as running out of disk
space) are unrecoverable.
If config-file is not specified,
config uses the current directory as the build
directory, and looks in it for a file called CONFIG.
config is run this way, the location of the
top-level kernel source directory must be specified using the
-s option or by using the
source” directive at the beginning of
the system configuration file.
The configuration files consists of various statements which include the following:
bsd root ondev [
swap ondev [
anddev ...]] [
bsd swap generic
To debug kernels and their crash dumps with gdb, add “makeoptions DEBUG="-g"” to the kernel configuration file. Refer to options(4) for further details.
Many other statements exist, and the file format is fairly rich;
for more information see the various configuration files included in the
system, as well as files.conf(5) for
config rules base.
-e is specified, device parameters
that are normally hard-coded into the kernel may be changed. This is useful
to avoid the need for kernel recompilation or rebooting. Modifications are
made to the currently running kernel and can be written to a new kernel
binary so changes are preserved during subsequent system restarts.
When invoked, the kernel identification is first shown.
# config -e -o bsd.new /bsd OpenBSD 5.3-current (GENERIC.MP) #91: Mon Mar 25 16:43:17 MDT 2013 email@example.com:/usr/src/sys/arch/i386/compile/GENERIC.MP Enter 'help' for information ukc>
One or more warnings may be printed before the
warning: no output file specified
-o option has been specified. Changes will be
WARNING kernel mismatch. -u ignored. WARNING the running kernel version:
config does not believe the running kernel
is the same as the infile specified. Since the log of
boot -c) in the running kernel is
-u option is ignored.
The commands are as follows:
changedevno | dev
disableattr val | devno | dev
enableattr val | devno | dev
finddevno | dev
The Ethernet card is not detected at boot because the kernel configuration does not match the physical hardware configuration, e.g. wrong IRQ in OpenBSD/i386. The Ethernet card is supposed to use the ne(4) driver.
find ne24 ne0 at isa0 port 0x240 size 0 iomem 0xd8000 iosiz 0 irq 9 drq -1 drq2 -1 flags 0x0 25 ne1 at isa0 port 0x300 size 0 iomem -1 iosiz 0 irq 10 drq -1 drq2 -1 flags 0x0 26 ne* at isapnp0 port -1 size 0 iomem -1 iosiz 0 irq -1 drq -1 flags 0x0 27 ne* at pci* dev -1 function -1 flags 0x0 28 ne* at pcmcia* function -1 irq -1 flags 0x0 ukc>
ne1 seems to match the configuration except it uses IRQ 10 instead
of IRQ 5. So the irq on ne1 should be changed via the
change command. The device can be specified by
either name or number.
change ne125 ne1 at isa0 port 0x300 size 0 iomem -1 iosiz 0 irq 10 drq -1 drq2 -1 change (y/n) ?
yport [0x300] ? size  ? iomem [-1] ? iosiz  ? irq  ?
5drq [-1] ? drq2 [-1] ? flags  ? 25 ne1 changed 25 ne1 at isa0 port 0x300 size 0 iomem -1 iosiz 0 irq 5 drq -1 drq2 -1 flags 0x0 ukc>
It's also possible to disable all devices with a common attribute. For example:
disable port 0x30025 ne1 disabled 72 we1 disabled 75 el0 disabled 77 ie1 disabled
show command is useful for finding
which devices have a certain attribute. It can also be used to find those
devices with a particular value for an attribute.
show slot2 ahc* at eisa0 slot -1 10 uha* at eisa0 slot -1 12 ep0 at eisa0 slot -1 17 ep* at eisa0 slot -1 102 ahb* at eisa0 slot -1 103 fea* at eisa0 slot -1 ukc>
show port 0x30025 ne1 at isa0 port 0x300 size 0 iomem -1 iosiz 0 irq 10 drq -1 drq2 -1 flags 0x0 72 we1 at isa0 port 0x300 size 0 iomem 0xcc000 iosiz 0 irq 10 drq -1 drq2 -1 flags 0x0 75 el0 at isa0 port 0x300 size 0 iomem -1 iosiz 0 irq 9 drq -1 drq2 -1 flags 0x0 77 ie1 at isa0 port 0x300 size 0 iomem -1 iosiz 0 irq 10 drq -1 drq2 -1 flags 0x0 ukc>
It is possible to add new devices, but only devices that were linked into the kernel. If a new device is added, following devices will be renumbered.
find ep11 ep0 at isa0 port -1 size 0 iomem -1 iosiz 0 irq -1 drq -1 drq2 -1 flags 0x0 12 ep0 at eisa0 slot -1 flags 0x0 13 ep0 at pci* dev -1 function -1 flags 0x0 14 ep* at isapnp0 port -1 size 0 iomem -1 iosiz 0 irq -1 drq -1 flags 0x0 15 ep* at isa0 port -1 size 0 iomem -1 iosiz 0 irq -1 drq -1 drq2 -1 flags 0x0 16 ep* at eisa0 slot -1 flags 0x0 17 ep* at pci* dev -1 function -1 flags 0x0 18 ep* at pcmcia* dev -1 irq -1 flags 0x0 ukc>
add ep1Clone Device (DevNo, 'q' or '?') ?
13Insert before Device (DevNo, 'q' or '?')
1414 ep1 at pci* dev -1 function -1 ukc>
change 1414 ep1 at pci* dev -1 function -1 change (y/n) ?
ydev [-1] ?
14function [-1] ? flags  ?
1814 ep1 changed 14 ep1 at pci* dev 14 function -1 flags 0x12 ukc>
When done, exit the program with the
ignore any changes while
quit writes the changes to
-f was given, else ignore changes).
The SYNOPSIS portion of each device in section 4 of the manual.
Building 4.4 BSD Systems with Config.
config program appeared in
4.1BSD and was completely revised in
appeared in OpenBSD 2.6.
Included files should start with an empty line or comment.
|September 6, 2019||OpenBSD-current|