|CDCE(4)||Device Drivers Manual||CDCE(4)|
cdce* at uhub?
cdcedriver provides support for USB Host-to-Host (aka USB-to-USB) bridges based on the USB Communication Device Class (CDC) and Ethernet subclass, including the following:
The USB bridge appears as a regular network interface on both sides, transporting Ethernet frames. USB 1.x bridges support speeds of up to 12Mbps, and USB 2.0 speeds of up to 480Mbps. Packets are received and transmitted over separate USB bulk transfer endpoints.
cdce driver does not support different
media types or options. For more information on configuring this device, see
Universal Serial Bus Class Definitions for Communication Devices, http://www.usb.org/developers/docs/devclass_docs/.
Data sheet Prolific PL-2501 Host-to-Host Bridge/Network Controller.
cdcedevice driver first appeared in OpenBSD 3.6.
cdcedriver was written by Craig Boston <email@example.com> based on the aue(4) driver written by Bill Paul <firstname.lastname@example.org> and ported to OpenBSD by Daniel Hartmeier <email@example.com>.
|December 10, 2017||OpenBSD-current|