|BOOT_SPARC64(8)||System Manager's Manual (sparc64)||BOOT_SPARC64(8)|
System boot blocks are installed using installboot(8), which prepares an FFS filesystem partition for boot-strapping from the PROM.
The boot program attempts to load the kernel from the selected boot device, which must currently be an SCSI (sd) or IDE (wd) disk drive, or a CD-ROM (cd), or an SCSI tape drive (st).
The UltraSPARC Open Firmware will normally look for a bootloader on the device specified by the boot-device variable. The OpenBSD bootloader will then look for a kernel named bsd by default, unless the boot-file variable is set, or a different filename has been specified in the boot command. To reset this variable to its default, empty, value, type the following:
To boot from a softraid(4) volume by default, boot-device must be set to a disk device hosting a chunk of the softraid volume:
setenv boot-device disk0
and boot-file must contain the (sr) device name of the softraid volume and optionally a partition letter and/or kernel:
setenv boot-file sr0a:/bsd
Autoboot is enabled by setting the auto-boot? variable to “true”, and is the factory default.
machine promat the prompt. If you do this accidentally you can continue whatever was in progress by typing
goat the PROM prompt, and then
contto return to the system.
|October 3, 2015||OpenBSD-current|