|ATOMIC_SWAP_UINT(9)||Kernel Developer's Manual||ATOMIC_SWAP_UINT(9)|
atomic_swap_ptr — atomic
unsigned int *p, unsigned
unsigned long *p,
unsigned long new);
void *p, void
The atomic_swap set of functions provide an interface for atomically performing swap operations with respect to interrupts and multiple processors in the system.
The value referenced by the pointer p is replaced by the value new.
atomic_swap_ptr() can all be called during autoconf,
from process context, or from interrupt context.
These functions return the value at p as it was before the swap operation.
The atomic_swap functions first appeared in NetBSD 5.0 and OpenBSD 5.5.
|July 18, 2014||OpenBSD-current|