|ADB(4)||Device Drivers Manual (macppc)||ADB(4)|
adb — introduction
to Apple Desktop Bus support
adb0 at macobio?
abtn* at adb?
akbd* at adb?
ams* at adb?
apm0 at adb?
piic0 at adb?
The Apple Desktop Bus (ADB) is the single-master, multiple-slave, low-speed serial bus interface used by Macintosh computers to connect input devices such as keyboards, mice, trackballs, and graphics tablets to the machine.
Originally developed for the Mac68K port, the
adb driver was heavily modified when it was ported
to the PowerPC architecture. During this port it seems that the original
adb event device was split into many smaller
adb devices such as the Apple
Brightness / Volume Control Button
(abtn(4)), some energy control
(apm(4)), and I2C controller
(piic(4)) were added to the PowerPC port
later to complement the ADB system.
OpenBSD provides support for the following devices:
adb interface first appeared in
NetBSD 0.9. It has been under development ever
since. The original
adb manpage was written by Colin
Wood for NetBSD/Mac68K.
Original ADB support was written by Bradley A. Grantham. The direct ADB routines were written by John P. Wittkoski.
|January 15, 2015||OpenBSD-current|