|ACPIDUMP(8)||System Manager's Manual||ACPIDUMP(8)|
acpidumpcommand stores ACPI tables from physical memory into files specified by prefix. If prefix specifies a directory, the generated files will be of the form <prefix>/<sig>.<id>. Otherwise, they will be named <prefix>.<sig>.<id>. “sig” is the signature of the ACPI Table; “id” is unique for each table.
Additionally a file called <prefix>/headers or <prefix>.headers will be created that contains additional human readable information pertaining to this specific dump.
The ACPICA disassembler is available through the OpenBSD ports tree or package system:
# pkg_add acpica $ iasl -d <prefix>.<sig>.<id>
acpidump requires the ability to open
/dev/kmem which may be restricted based upon the
value of the kern.allowkmem
acpidump is run at startup and stores the
results in /var/db/acpi.
acpidumpcommand first appeared in OpenBSD 3.8.
|June 1, 2017||OpenBSD-current|