|ATOMIC_SWAP_UINT(9)||Kernel Developer's Manual||ATOMIC_SWAP_UINT(9)|
unsigned int *p, unsigned
unsigned long *p,
unsigned long new);
void *p, void
The value referenced by the pointer p is replaced by the value new.
atomic_swap_ptr() can all be called during autoconf, from process context, or from interrupt context. atomic_cas_uint(9) NetBSD 5.0 and OpenBSD 5.5.
|July 18, 2014||OpenBSD-current|