|NETGROUP_MKDB(8)||System Manager's Manual||NETGROUP_MKDB(8)|
generate the netgroup databases
netgroup_mkdb creates Berkeley databases
for the specified file. If no file is specified,
/etc/netgroup is used. These databases are then
installed into /etc/netgroup.db. The file must be in
the correct format (see
The options are as follows:
The databases are used by the C library netgroup routines (see getnetgrent(3)).
netgroup_mkdb utility exits 0
on success, and >0 if an error occurs.
netgroup_mkdb guarantees not to
install a partial destination file it must build a temporary file in the
same file system and if successful use
rename(2) to install over the destination
netgroup_mkdb fails it will leave the
previous version of the destination file intact.
|June 7, 2018||OpenBSD-current|