|LDCONFIG(8)||System Manager's Manual||LDCONFIG(8)|
ldconfigis used to prepare a set of “hints” for use by the run-time linker ld.so(1) to facilitate quick lookup of shared libraries available in multiple directories. It scans a set of built-in system directories and any directories specified on the command line (in the given order) looking for shared libraries and stores the results in the file /var/run/ld.so.hints to forestall the overhead that would otherwise result from the directory search operations ld.so(1) would have to perform to load the required shared libraries.
The shared libraries so found will be automatically available for loading if needed by the program being prepared for execution. This obviates the need for storing search paths within the executable.
LD_LIBRARY_PATH environment variable
can be used to override the use of directories (or the order thereof) from
the cache or to specify additional directories where shared libraries might
LD_LIBRARY_PATH is a ‘:’
separated list of directory paths which are searched by
ld.so(1) when it needs to load a shared
library. It can be viewed as the run-time equivalent of the
-L switch of
ldconfig is typically run as part of the
boot sequence. In addition to the built-in system directories, directories
containing shared libraries may be specified via the
shlib_dirs variable in
rc.conf(8) for further information.
The following options are recognized by
set-user-Idprograms. Whenever such a program is run, ld.so(1) will only load shared libraries from the ld.so.hints file. In particular, the
LD_LIBRARY_PATHis not used to search for libraries. Thus, the role of
ldconfigis dual. In addition to building a set of hints for quick lookup, it also serves to specify the trusted collection of directories from which shared objects can be safely loaded. It is presumed that the set of directories specified to
ldconfigare under control of the system's administrator. ld.so(1) further assists set-user-Id programs by erasing the
LD_LIBRARY_PATHfrom the environment.
ldconfigutility first appeared in SunOS 4.0. It appeared in its current form in NetBSD 0.9A.
|July 4, 2016||OpenBSD-current|