|UPD(4)||Device Drivers Manual||UPD(4)|
upd* at uhidev?
upddriver provides support for monitoring various sensors provided by USB Power Devices (such as a UPS). Supported sensor values are made available via the sysctl(8) interface.
The following sensors are supported by the driver:
The USB Power Devices specification can be found at http://www.usb.org/developers/hidpage/
upddriver first appeared in OpenBSD 5.6.
upddriver was written by Andre de Oliveira.
upddriver does not indicate device health via aggregate or individual sensor status. Users who wish to monitor
updstatus using sensorsd(8) must manually establish “high” and “low” limits for sensor values of interest via sensorsd.conf(5).
|June 26, 2015||OpenBSD-current|