|ONERNG(4)||Device Drivers Manual||ONERNG(4)|
uonerng — Moonbase
Otago OneRNG TRNG
uonerng* at uhub?
uonerng driver provides support for
the Moonbase Otago OneRNG, a USB true random number generator (TRNG).
uonerng reads raw entropy from the OneRNG and uses
enqueue_randomness(9) to add
it to the system entropy pool.
The OneRNG is capable of operating in one of several modes, some of which are intended for production use and some of which are for testing and validating the hardware.
uonerng operates in the “Avalanche
noise with whitener” mode, which is also the manufacturer's default
Moonbase Otago: http://onerng.info/onerng
uonerng driver first appeared in
uonerng driver was written by
The OneRNG permits downloading of the device firmware so that one
may check the firmware's cryptographic signature as provided by the
uonerng driver does not perform
nor support this action. In order to currently perform such a validation, it
would be necessary to disable
uonerng in the kernel
and then download the firmware via the OneRNG's emulated AT modem command
|April 28, 2018||OpenBSD-current|