|SKGPIO(4)||Device Drivers Manual (i386)||SKGPIO(4)|
skgpio0 at isa? port 0x680
gpio* at skgpio?
skgpiodriver provides support for the GPIO and LEDs as implemented by the Xilinx Spartan FGPA integrated into the Soekris net6501 programmed with the default bitstream found in the BIOS.
Two standard gpio(4) interfaces are provided, one for the 16 real pins which can be configured as either inputs or outputs and another with 2 output-only pins that map to the error and ready LEDs respectively. Both may be used with gpioctl(8).gpio(4), intro(4), isa(4), gpioctl(8)
skgpiodriver first appeared in OpenBSD 5.7.
skgpiodriver was written by Matt Dainty ⟨firstname.lastname@example.org⟩.
|October 22, 2015||OpenBSD-current|