|BWI(4)||Device Drivers Manual||BWI(4)|
bwi — Broadcom
AirForce IEEE 802.11b/g wireless network device
bwi* at cardbus?
bwi* at pci?
bwi driver provides support for
Broadcom AirForce based PCI/Cardbus network adapters.
These are the modes the
bwi driver can
bwi driver can be configured to use
Wired Equivalent Privacy (WEP) or Wi-Fi Protected Access (WPA1 and WPA2).
WPA2 is the current encryption standard for wireless networks. It is
strongly recommended that neither WEP nor WPA1 are used as the sole
mechanism to secure wireless communication, due to serious weaknesses. WPA1
is disabled by default and may be enabled using the option
wpa1,wpa2". For standard WPA networks which use
pre-shared keys (PSK), keys are configured using the
wpakey" option. WPA-Enterprise networks
require use of the wpa_supplicant package. The
driver relies on the software 802.11 stack for both encryption and
decryption of data frames.
The transmit speed is user-selectable or can be adapted automatically by the driver depending on the received signal strength and on the number of hardware transmission retries.
The driver needs a firmware file which is loaded when an interface is brought up:
A prepackaged version of the firmware can be installed using fw_update(1).
The following cards are among those supported by the
|Apple Airport Extreme||BCM4306||PCI||b/g|
|Apple Airport Extreme||BCM4318||PCI||b/g|
|Compaq R4035 onboard||BCM4306||PCI||b/g|
|Linksys WPC54G Ver 3||BCM4318||CardBus||b/g|
|Linksys WPC54GS Ver 2||BCM4318||CardBus||b/g|
|US Robotics 5411||BCM4318||CardBus||b/g|
The following example scans for available networks:
# ifconfig bwi0 scan
The following hostname.if(5) example configures bwi0 to join network “mynwid”, using WPA key “mywpakey”, obtaining an IP address using DHCP:
nwid mynwid wpakey mywpakey dhcp
bwi driver first appeared in
bwi driver was written for
DragonFly by Sepherosa
Ziehau and ported to OpenBSD by
Jonathan Gray and Marcus
Some chips are incorrectly calibrated due to the lack of documentation, which can slow the amount of traffic to the point of being unusable. Furthermore this driver only supports firmware version 3.
This driver does not support powersave mode.
|November 10, 2019||OpenBSD-current|