|ATH(4)||Device Drivers Manual||ATH(4)|
ath — Atheros IEEE
802.11a/b/g wireless network device with GPIO
ath* at pci? dev ? function ?
ath* at cardbus? dev ? function ?
gpio* at ath?
ath driver provides support for
wireless network devices based on the Atheros AR5210, AR5211, and AR5212
All host/device interaction is via DMA. The
ath driver encapsulates all IP and ARP traffic as
802.11 frames, though it can receive either 802.11 or 802.3 frames. Transmit
speed and operating mode is selectable and depends on the specific
Support for the various devices is as follows:
The actual transmit speed used is dependent on signal quality and the “rate control” algorithm employed by the driver.
These are the modes the
ath driver can
ath driver can be configured to use
Wired Equivalent Privacy (WEP) or Wi-Fi Protected Access (WPA1 and WPA2).
WPA2 is the current encryption standard for wireless networks. It is
strongly recommended that neither WEP nor WPA1 are used as the sole
mechanism to secure wireless communication, due to serious weaknesses. WPA1
is disabled by default and may be enabled using the option
wpa1,wpa2". For standard WPA networks which use
pre-shared keys (PSK), keys are configured using the
wpakey" option. WPA-Enterprise networks
require use of the wpa_supplicant package.
AR5211 and AR5212 support the AES, TKIP, and Michael cryptographic operations required for WPA in hardware but at this time the driver does not support them.
In BSS mode, the driver supports powersave mode, which can be enabled via ifconfig(8).
Devices supported by the
ath driver come
in either CardBus or Mini PCI packages. Wireless cards in CardBus slots may
be inserted and ejected on the fly.
The following cards are among those supported by the
|IBM 11ABG WL LAN||AR5212||Mini PCI||a/b/g|
|Proxim Skyline 4030||AR5210||CardBus||a|
|Proxim Skyline 4032||AR5210||PCI||a|
|Senao NL-5354MP||AR5212||Mini PCI||a/b/g|
|Wistron CM9||AR5212||Mini PCI||a/b/g|
The following example scans for available networks:
# ifconfig ath0 scan
The following hostname.if(5) example configures ath0 to join network “mynwid”, using WPA key “mywpakey”, obtaining an IP address using DHCP:
nwid mynwid wpakey mywpakey inet autoconf
The following hostname.if(5) example creates a host-based access point on boot:
mediaopt hostap nwid mynwid wpakey mywpakey inet 192.168.1.1 255.255.255.0
ath device driver first appeared in
FreeBSD 5.2 using a binary-only HAL module which was
ported to NetBSD 2.0. The driver using a free
HAL-replacement first appeared in OpenBSD 3.7.
ath driver was written by
Sam Leffler, and was ported to
OpenBSD by Reyk Floeter
who also wrote a free replacement of the binary-only HAL.
Different regulatory domains may not be able to communicate with each other with 802.11a as different regulatory domains do not necessarily have overlapping channels.
Host AP mode doesn't support power saving. Clients attempting to use power saving mode may experience significant packet loss (disabling power saving on the client will fix this).
Performance in lossy environments is suboptimal. The algorithm used to select the rate for transmitted packets is very simplistic. There is no software retransmit; only hardware retransmit is used. Contributors are encouraged to replace the existing rate control algorithm with a better one.
The driver does not fully enable power-save operation of the chip; consequently power use is suboptimal.
Operation in the 2GHz band is restricted to 11b mode because the driver does not support running the hardware in 11g mode.
|October 15, 2021||OpenBSD-current|