|AHCI(4)||Device Drivers Manual||AHCI(4)|
ahci* at acpi?
ahci* at fdt?
ahci* at pci?
ahci* at jmb?
ahcidriver provides support for Serial ATA controllers conforming to the Advanced Host Controller Interface specification.
Several AHCI capable controllers also provide a compatibility mode that causes them to appear as a traditional ATA controller supported by pciide(4).
ahci controllers are actual ATA
controllers, the driver emulates SCSI via a translation layer.
Setting the lowest bit (0x1) of the driver flags forces
ahci to negotiate SATA 1 (1.5 Gb/s) transfer speeds
only. It may be useful where higher speeds are unstable.
ahcidriver first appeared in OpenBSD 4.1.
ahcidriver was written by David Gwynne <email@example.com> and Christopher Pascoe <firstname.lastname@example.org>.
|July 2, 2018||OpenBSD-current|