|WSKBD(4)||Device Drivers Manual||WSKBD(4)|
wskbd — generic
keyboard support in wscons
wskbd* at ...
wskbd driver handles common tasks for
keyboards within the
wscons(4) framework. It is
attached to the hardware specific keyboard drivers and provides their
connection to “wsdisplay” devices and a character device
The common keyboard support consists of:
wskbd driver provides a number of
ioctl functions to control key maps and other parameters. These functions
are accessible through the associated “wsdisplay” device as
well. A complete list is in
allows access to key maps and other variables.
in the configuration line refers to the device's use as input part of the
operating system console. A device specification containing a positive value
here will only match if the device is in use as system console. (The console
device selection in early system startup is not influenced.) This way, the
console device can be connected to a known
wskbd driver traps certain key
sequences intended to perform special functions. The
Ctrl+Alt+Esc sequence will initiate the
ddb(4) kernel debugger if the
sysctl(8) variable is set.
When attached to a
Ctrl+Alt+Fx switches virtual terminals and the
combinations provide scrollback functionality if the underlying hardware
driver supports it. When audio devices are supported, keys
VolumeDown tweak mixer settings.
|September 3, 2016||OpenBSD-7.0|