|VMM(4)||Device Drivers Manual (amd64)||VMM(4)|
vmm — virtual
vmm0 at mainbus0
vmm driver implements a virtual
machine monitor (VMM) suitable for executing
machines (VMs). A VMM runs on the
operating system and provides facilities to execute one or more VMs, each of
which is provided with a suitable complement of virtual hardware.
These VMs run independently of the host, but may interact with it as any other machine would (e.g. via network communications or other means).
VMs are allocated hardware resources by the VMM during creation, including:
Although VMs execute independently of each other and the host, they do consume host resources and, as such, the number of VMs (and their configurations) should be taken into consideration when planning host capacity.
vmm driver requires suitable host CPU
capabilities in order to provide VM services. The
vmm driver requires at least one CPU with
hardware-assisted virtualization capabilities and nested or extended paging
capabilities to be present on the host. For more information, consult the
CPU vendor's documentation.
ioctl(2) commands are provided
VMM_IOC_CREATEstruct vm_create_params *
vmmif not yet started. (Does not start the VCPU.)
VMM_IOC_RUNstruct vm_run_params *
VMM_IOC_INFOstruct vm_info_params *
VMM_IOC_TERMstruct vm_terminate_params *
VMM_IOC_RESETCPUstruct vm_resetcpu_params *
VMM_IOC_INTRstruct vm_intr_params *
VMM_IOC_READREGSstruct vm_rwregs_params *
VMM_IOC_WRITEREGSstruct vm_rwregs_params *
VMM_IOC_READVMPARAMSstruct vm_revmparams_params *
VMM_IOC_WRITEVMPARAMSstruct vm_rwvmparams_params *
VMM_IOC_MPROTECT_EPTstruct vm_mprotect_ept_params *
vmm driver appeared in
Mike Larkin <email@example.com>
|April 2, 2021||OpenBSD-7.0|