|UNWIND(8)||System Manager's Manual||UNWIND(8)|
validating DNS resolver
unwind is a validating DNS resolver. It is
intended to run on client machines like workstations or laptops and only
listens on localhost.
unwind sends DNS queries to
nameservers to answer queries and switches to resolvers learned from
slaacd(8) if it detects that
DNS queries are blocked by the local network. It periodically probes if DNS
is no longer blocked and switches back to querying nameservers itself.
unwind keeps the DNS answers in a cache
shared by the different DNS name server types.
unwind manages the cache size by deleting oldest
entries when needed. The cache is non-configurable and is lost upon process
unwind enabled at boot time, use
“rcctl enable unwind”, which sets
unwind can be controlled with
The options are as follows:
unwindwill run in the foreground and log to stderr.
-voptions increase the verbosity. Debug output from libunbound is only available when logging to stderr.
P. Mockapetris, DOMAIN NAMES - CONCEPTS AND FACILITIES, RFC 1034, November 1987.
P. Mockapetris, DOMAIN NAMES - IMPLEMENTATION AND SPECIFICATION, RFC 1035, November 1987.
unwind program first appeared in
unwind program was written by
|July 18, 2021||OpenBSD-7.0|