|APMD(8)||System Manager's Manual||APMD(8)|
apmd — Advanced
Power Management daemon
For suspend and standby request events delivered by the BIOS, or
apmd runs the appropriate configuration program (if
one exists), syncs the buffer cache to disk and initiates the requested
state. When resuming after suspend or standby,
runs the appropriate configuration program (if one exists).
When the power status changes (battery is connected or
apmd fetches the current status and
reports it via syslog(3) with
The options are as follows:
apmdin automatic performance adjustment mode.
apmdenters debug mode, staying in the foreground. Logging output is printed to stderr.
apmdin manual performance adjustment mode, initialising hw.setperf to 100.
apmdin manual performance adjustment mode, initialising hw.setperf to 0.
apmdexits without monitoring the APM status.
apmdperiodically polls the APM driver for the current power state. If the battery charge level changes substantially or the external power status changes, the new status is logged. The polling rate defaults to once per 10 minutes, but may be specified using the
-z are specified, the last one will supersede
the other. After a resume, the effect of those options is inhibited for
When a client requests a suspend or stand-by state,
apmd does not wait for positive confirmation that
the requested state has been entered before replying to the client; to do so
would mean the client does not get a reply until the system resumes from its
sleep state. Rather,
apmd replies with the intended
state to the client and then places the system in the requested state after
running the configuration script and flushing the buffer cache.
Actions can be configured for the following transitions: suspend,
hibernate, standby, resume, powerup, and powerdown. The suspend, hibernate
and standby actions are run prior to
any other actions (such as disk syncs) and entering the new state. The
resume program is run after resuming from a stand-by or suspended state. The
powerup and powerdown programs are run after the power status (AC connected
or not) changes, as well as after a resume (if the power status changed in
the mean time).
Advanced Power Management (APM) BIOS Interface Specification (revision 1.2), Intel Corporation and Microsoft Corporation.
apmd command first appeared in
NetBSD 1.3. OpenBSD support
was added in OpenBSD 1.2.
|March 13, 2020||OpenBSD-7.0|