|VNSUBR(9)||Kernel Developer's Manual||VNSUBR(9)|
vn_writechk — high-level
convenience functions for vnode operations
vnode *vp, int
flags, struct ucred
*cred, struct proc
vnode *dvp, struct vnode
*rvp, struct proc
vnode *vp, int
nameidata *ndp, int
vn_rdwr(enum uio_rw rw,
struct vnode *vp, caddr_t base,
int len, off_t offset,
enum uio_seg segflg, int ioflg,
struct ucred *cred, size_t
*aresid, struct proc *p);
vnode *vp, struct stat
*sb, struct proc
The high-level functions described in this page are convenience functions for simplified access to the vnode operations described in VOP_LOOKUP(9).
vn_close(vp, flags, cred, p)
vn_close() simply locks the vnode, invokes the vnode operation
VOP_CLOSE() and calls vput(9) to return the vnode to the freelist or holdlist. Note that
vn_close() expects an unlocked, referenced vnode and will dereference the vnode prior to returning. If the operation is successful, zero is returned; otherwise an appropriate error is returned.
vn_isunder(dvp, rvp, p)
vn_isunder() is intended to be used in chroot(2), chdir(2), fchdir(2), etc., to ensure that chroot(2) actually means something. If the operation is successful, zero is returned; otherwise 1 is returned.
function can sleep.
vn_open(ndp, fmode, cmode)
The pathname is described in the
nameidata structure pointed to by the
ndp argument. When initializing the nameidata
with NDINIT(9), the
op must be specified as 0, and the
flags may only be 0, or
KERNELPATH. The lookup mode and flags are set
The arguments fmode and
cmode specify the
open(2) file mode and the
access permissions for creation.
checks permissions and invokes the
operations. If the operation is successful, zero is returned; otherwise
an appropriate error code is returned.
vn_rdwr(rw, vp, base, len, offset, segflg, ioflg, cred, aresid, p);
UIO_READ) or write (
UIO_WRITE) operation. The unlocked vnode is specified by vp. The arguments p and cred are the calling process and its credentials. The remaining arguments specify the uio parameters. For further information on these parameters, see uiomove(9).
vn_stat(vp, sb, p)
vn_stat() basically calls the vnode operation VOP_GETATTR(9) and transfers the contents of a vattr structure into a struct stat. If the operation is successful, zero is returned; otherwise an appropriate error code is returned.
ETXTBSYis returned; otherwise zero is returned to indicate that the vnode can be written to.
This section describes places within the OpenBSD source tree where actual code implementing or using the vnode framework can be found. All pathnames are relative to /usr/src.
The high-level convenience functions are implemented within the files sys/kern/vfs_vnops.c and sys/sys/vnode.h.
The locking discipline is bizarre. Many vnode operations are passed locked vnodes on entry but release the lock before they exit. Discussions with Kirk McKusick indicate that locking discipline evolved out of the pre-VFS way of doing inode locking. In addition, the current locking discipline may actually save lines of code, especially if the number of file systems is fewer than the number of call sites. However, the VFS interface would require less wizardry if the locking discipline were simpler.
The locking discipline is used in some places to attempt to make a series of operations atomic (e.g., permissions check + operation). This does not work for non-local file systems that do not support locking (e.g., NFS).
Are vnode locks even necessary? The security checks can be moved into the individual file systems. Each file system can have the responsibility of ensuring that vnode operations are suitably atomic.
LK_NOWAIT flag does prevent the caller
The locking discipline as it relates to shared locks has yet to be defined.
|October 6, 2019||OpenBSD-6.9|