OpenBSD manual page server

Manual Page Search Parameters

VDEVGONE(9) Kernel Developer's Manual VDEVGONE(9)

vdevgonerevoke all specified minor numbered vnodes for a device

#include <sys/param.h>
#include <sys/vnode.h>

void
vdevgone(int maj, int minl, int minh, enum vtype type);

The () function will revoke all the vnodes corresponding to the specified minor number range for the device with a major number of maj and of type type.

Its arguments are:

maj
The major number of the device.
minl
The lowest minor number for the device to be revoked.
minh
The highest minor number for the device to be revoked.
type
The type of the device; this must be one of:
Device is a block device
Device is a character device

The endpoints specified by minl and minh are inclusive.

vfinddev(9), vnode(9)

This man page was originally written for OpenBSD.

November 14, 2020 OpenBSD-6.9