|TCP(4)||Device Drivers Manual||TCP(4)|
tcp — Internet
Transmission Control Protocol
The TCP protocol provides a reliable, flow-controlled, two-way
transmission of data. It is a byte-stream protocol used to support the
SOCK_STREAM abstraction. TCP uses the standard
Internet address format and, in addition, provides a per-host collection of
“port addresses”. Thus, each address is composed of an
Internet address specifying the host and network, with a specific TCP port
on the host identifying the peer entity.
Sockets utilizing the TCP protocol are either “active” or “passive”. Active sockets initiate connections to passive sockets. By default TCP sockets are created active; to create a passive socket the listen(2) system call must be used after binding the socket with the bind(2) system call. Only passive sockets may use the accept(2) call to accept incoming connections. Only active sockets may use the connect(2) call to initiate connections.
Passive sockets may “underspecify” their location to
match incoming connection requests from multiple networks. This technique,
termed “wildcard addressing”, allows a single server to
provide service to clients on multiple networks. To create a socket which
listens on all networks, the Internet address
INADDR_ANY must be bound. The TCP port may still be
specified at this time; if the port is not specified the system will assign
one. Once a connection has been established the socket's address is fixed by
the peer entity's location. The address assigned to the socket is the
address associated with the network interface through which packets are
being transmitted and received. Normally this address corresponds to the
peer entity's network.
<netinet/tcp.h>), to defeat this algorithm.
A socket operation may fail with one of the following errors returned:
tcp protocol stack appeared in
|May 11, 2018||OpenBSD-6.9|