|SPAMLOGD(8)||System Manager's Manual||SPAMLOGD(8)|
spamlogd — spamd
whitelist updating daemon
spamlogd manipulates the
spamd(8) database in
/var/db/spamd used for greylisting.
spamlogd updates the
/var/db/spamd whitelist entries whenever a
connection to port 25 is logged to the
pflog(4) interface. The source
addresses of inbound connections are whitelisted when seen by
spamlogd to ensure that their entries in
/var/db/spamd do not expire if the connecting host
continues to send legitimate mail. The destination addresses of outbound
connections are whitelisted when seen by
that replies to outbound mail may be received without initial greylisting
delays. Greylisting is explained more fully in
The options are as follows:
spamlogddoes not disassociate from the controlling terminal.
spamlogdis only to whitelist inbound SMTP connections. By default
spamlogdwill whitelist the source of inbound SMTP connections, and the target of outbound SMTP connections.
It is important to log any connections to and from the real MTA in
spamlogd to update the whitelist entries.
See spamd(8) for an example
ruleset for logging such connections.
spamlogd supports realtime synchronisation
of whitelist states by sending the information it updates to a number of
spamd(8) daemons running on
multiple machines. To enable synchronisation, use the command line option
-Y to specify the machines to which
spamlogd will send messages when it updates the
state information. For more information, see
spamlogd command first appeared in
|September 15, 2013||OpenBSD-6.9|