|power(4/hppa)||power button and power fail support|
|POWER(4)||Device Drivers Manual (hppa)||POWER(4)|
power — power
button and power fail support
power0 at mainbus?
HP PA-RISC machines support power failure detection in different forms:
power driver tries its best to
determine the power failure condition that is a result of a power button
being depressed or a power supply system failure or a similar condition.
Upon detection of any of the aforementioned conditions, it tries to
gracefully (if possible) shutdown the system through a call to the
On systems equipped with the lasi(4) bus adapter, we find a “soft” power button which upon depression gives us a signal in the “power register” and thus polling periodically we detect the event. Since that bit comes directly from the power button without any dampening, we perform a second long delay; thus quick transitions off and on will not result in a shutdown.
On modern systems, an interruption is signalled upon the power button depression and thus this avoids polling and does not require (as does being implemented in hardware) dampening.
power driver appeared in
|May 31, 2007||OpenBSD-6.9|