|MIXERCTL(8)||System Manager's Manual||MIXERCTL(8)|
manipulate controls for audio hardware
mixerctl command displays or sets
various controls for audio hardware, such as microphone reference voltage or
output level. Where hardware defaults are not the desired ones, controls can
be set at system startup using the configuration file
mixerctl itself can only be run by the
superuser. Common controls should be adjusted at runtime using
sndioctl(1), which is
intended for every day use and requires no superuser privileges. Manual use
mixerctl is intended for controls which cannot be
set using sndioctl(1).
If a list of control names is present on the command line,
mixerctl prints the current value of those controls
for the specified device.
The options are as follows:
The exact set of controls that can be manipulated depends on the device. The general format (in both getting and setting a value) is:
The class can have values like “inputs” or “outputs”, indicating that the control affects the input or output, respectively, to the device. The name indicates what part of the device the control affects. Continuous values, e.g. volume, have numeric values in the range 0-255. If value can be set for each channel independently, the values are printed separated by commas. Discrete values, e.g. the recording source, have symbolic names.
Variables may take one of three types, again dependent on the mixer:
+’ or ‘
-’ to denote an increase or decrease, respectively.
Show possible values for all controls, and their current settings:
# mixerctl -av inputs.mic=0,0 volume inputs.mic.mute=off [ off on ] inputs.cd=220,220 volume inputs.cd.mute=off [ off on ] inputs.dac=220,220 volume inputs.dac.mute=off [ off on ] record.record=220,220 volume record.record.source=mic [ mic cd dac ] monitor.monitor=0 volume
# mixerctl -t inputs.dac.mute inputs.dac.mute: off -> on # mixerctl inputs.dac.mute=toggle inputs.dac.mute: on -> off
mixerctl command first appeared in
|April 23, 2020||OpenBSD-6.9|