|ZS(4)||Device Drivers Manual (sparc64)||ZS(4)|
Zilog 8530 (ZSCC) serial communications driver
zs* at fhc?
zs* at sbus?
zstty* at zs?
zskbd* at zs?
wskbd* at zskbd?
zsms* at zs?
wsmouse* at zsms?
zs is a Zilog 8530 serial interface
chip used in SBus-based UltraSPARC Sun workstations. The Zilog 8530 provides
two input/output channels per instance. Most Sun workstations include two of
these interfaces. One of the interfaces is usually hardwired for use by the
keyboard and mouse attached to the workstation console. The
zskbd devices connect keyboard devices to the
generic keyboard driver
zsms devices connect mice to the generic mouse
driver wsmouse(4). The
zs interfaces provide RS-423
and RS-232 serial ports for general purpose use.
zs driver supports all of the standard
tty(4) ioctl calls. The status
of the DTR, RTS, CTS, and DCD signals can be queried with TIOCMGET command,
but, due to limitations in the hardware, only the DTR and RTS signals can be
modified with TIOCMSET, TIOCMBIC, and TIOCMBIS
zskbd driver supports a number of
different key mappings. By default, the layout corresponding to the keyboard
model as probed by the
zskbd driver will be used. A
different layout can be chosen either with the kernel options
“SUNKBD_LAYOUT” (for type 4 keyboards) and
“SUNKBD5_LAYOUT” (for type 5 keyboards) at compile time or
with the utility
“keyboard.encoding”) at runtime.
Other mappings can be used if the whole keymap is replaced by means of wsconsctl(8). The built-in mappings are at this time:
The KB_SV mapping can be used in the KB_NODEAD (.nodead) variant. This switches off the “dead accents”.
To set a German keyboard layout, use
keyboard.encoding=de. To set it at kernel build time, add the
following to the kernel configuration file for a type 4 keyboard:
For a type 5 keyboard:
zs driver first appeared in
4.4BSD. Support for the TIOCM*
ioctl(2)s appeared in
zs driver now supports cua minor
devices, but with this known deficiency in the simultaneous
outgoing/incoming aspect of the driver: The first outgoing connection
succeeds, but second and subsequent connections fail, apparently due to a
getty hang. The hung getty apparently prevents the cua device from being
The kernel does not provide a keyboard layout for all manufactured Sun keyboard models.
|November 21, 2015||OpenBSD-6.9|