|ZS(4)||Device Drivers Manual (alpha)||ZS(4)|
Zilog 8530 (ZSCC) Serial Communications
zs* at ioasic0
zstty* at zs?
zs driver provides TTY support for the
two Zilog 8530 Dual UART chips found on DEC 3000 systems. On these systems,
two of these serial interfaces are hardwired for use by the keyboard and
mouse. Only the second interface of each
controller can be used as a regular serial port. The
zstty interfaces provide RS-423 and RS-232 serial
ports for general purpose use.
zs driver supports all of the standard
tty(4) ioctl calls. The status
of the DTR, RTS, CTS, and DCD signals can be queried with the TIOCMGET
command but, due to limitations in the hardware, only the DTR and RTS
signals can be modified with the TIOCMSET, TIOCMBIC, and TIOCMBIS
Input and output for each line may be set to any baud rate in the range 50 to 38400.
|November 2, 2017||OpenBSD-6.9|