|LOGIN_PASSWD(8)||System Manager's Manual||LOGIN_PASSWD(8)|
provide standard password authentication type
The user argument is the login name of the user to be authenticated.
The service argument specifies which protocol to use with the invoking program. The allowed protocols are login, challenge, and response. (The challenge protocol is silently ignored but will report success as passwd-style authentication is not challenge-response based).
wheel argument is specified and is
not set to
yes, then the user will be rejected as
not being in group “wheel”. This is used by
lastchance argument is specified
and is equal to
yes, then if the user's password has
expired, and it has not been expired longer than
“password-dead” seconds (see
login.conf(5)), the user
will be able to log in one last time to change the password.
login_passwd will prompt the user for a
password and report back to the invoking program whether or not the
authentication was successful.
|January 25, 2019||OpenBSD-6.9|