|APS(4)||Device Drivers Manual||APS(4)|
aps — ThinkPad
Active Protection System accelerometer
aps0 at isa? port 0x1600
aps driver provides support for
several sensors found in some ThinkPad laptops.
The sensors currently exposed via the sysctl(8) interface are:
||Unknown||Weighted X Acceleration?|
||Unknown||Weighted Y Acceleration?|
aps driver first appeared in
aps driver was written by
aps driver does not yet maintain state
and subsequently does not take evasive action when it thinks the hard drive
is in danger.
The Y axis on X40 and possibly other models seems to be inverted. It is unknown how to distinguish between different versions of the accelerometer to compensate for this in the driver at this time.
As IBM provides no documentation, it is not known what all the available sensors are used for.
|July 16, 2013||OpenBSD-6.9|