|ULPT(4)||Device Drivers Manual||ULPT(4)|
ulpt — USB printer
ulpt* at uhub?
ulpt driver provides support for USB
printers that follow the printer bi- or uni-directional protocol. The bits
in the minor number select various features of the driver.
|64||Do not initialize the device on the port.|
For some HP LaserJet printer models (1000, 1005, 1018, 1020), the driver needs at least version 1.0 of the following firmware files, which are loaded when a printer is attached:
These firmware files are not free because HP refuses to grant distribution rights. As a result, even though OpenBSD includes the driver, the firmware files cannot be included and users have to download these files on their own. A port which can download and install the firmware can be found in /usr/ports/sysutils/firmware/ulpt.
ulpt driver appeared in
NetBSD 1.4. OpenBSD support
was added in OpenBSD 2.7.
|February 4, 2013||OpenBSD-6.8|