|SYSUPGRADE(8)||System Manager's Manual||SYSUPGRADE(8)|
upgrade system to the next release or a new
sysupgrade is a utility to upgrade
OpenBSD to the next release or a new snapshot if
sysupgrade downloads the necessary files
to /home/_sysupgrade, verifies them with
signify(1), and copies
bsd.rd to /bsd.upgrade.
sysupgrade by default then reboots the
system. The bootloader will automatically choose
/bsd.upgrade, triggering a one-shot upgrade using
the files in /home/_sysupgrade.
The options are as follows:
sysupgrade first appeared in
|October 3, 2019||OpenBSD-6.8|