|HSQ(4)||Device Drivers Manual||HSQ(4)|
hsq — multiplexing
serial communications interface
hsq0 at isa? port 0x140 irq 10
com* at hsq?
hsq driver provides support for
Corporation) and compatible boards that multiplex together up to four
EIA RS-232C (CCITT V.28) communications interfaces.
hsq device is the master device for
up to four
com devices. The kernel configuration
com devices as slave devices of the
hsq device, as shown in
SYNOPSIS. The slave ID given for each
com device determines which bit in the interrupt
multiplexing register is tested to find interrupts for that device. The
port specification for the
hsq device is used to compute the base addresses for
com subdevices (they are equal to port + ID * 8)
and the port for the interrupt multiplexing register (it is equal to port +
7). More technical details on how the driver works can be found in the big
comment at the beginning of the driver's source code.
Information on setup of card's configuration switches should be taken from Comtrol Corporation's web site, since the author wrote and tested the driver only with Hostess-compatible cards.
hsq driver was written by
Denis A. Doroshenko based on the
|January 3, 2018||OpenBSD-6.8|