|GROWFS(8)||System Manager's Manual||GROWFS(8)|
growfs — grow size
of an existing ffs file system
growfs utility extends the
newfs(8) program. Before
growfs, the partition must be set to a
larger size using
growfs utility extends the size of the file system
on the specified special file.
growfs can only enlarge
unmounted file systems. Do not try enlarging a mounted file system - your
system may panic and you will not be able to use the file system any longer.
Most of the newfs(8) options
cannot be changed by
growfs. In fact, you can only
increase the size of the file system. Use
tunefs(8) for other
The following options are available:
growfswill not print extraneous information like superblock backups.
growfswill enlarge the file system to the size of the entire partition).
growfswill ask you if you have taken a backup of your data and will test whether special is currently mounted. The
-yflag suppresses this, so use this option with great care!
growfsdefaults to the terminal width, or 80 columns if the output is not a terminal.
growfs utility first appeared in
FreeBSD 4.4 and has been available since
Filesystems must be checked with fsck(8) after enlarging.
|October 17, 2017||OpenBSD-6.8|